Snow Leopard upgrade, Firefox crash

I ran across a problem that only seems to happen to people who use Firefox 3.5 (maybe other versions) with profiles (which I do, to separate dev plugins/links from the rest) who upgrade a Mac to Snow Leopard.

When you start Firefox from the command line with:

…you get a crash that complains about not having the right version of libsqlite3.dylib.

I did find a fix here, but you have to dig to find it, so I’ll lay it out step by step. Open a terminal window (I recommend iTerm, but the OS X terminal app will do), and do the following:

Now try restarting Firefox with your desired profile again.